Nach einem Neustart des SharePoint Servers startet der Dienst SPAdminV4 nicht automatisch und folgende Eventlog Einträge sind vorhanden:

7009

Log Name:      System
Source:        Service Control Manager
Date:          12.11.2013 11:22:33
Event ID:      7009
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxxxxxxxxxx
Description:
A timeout was reached (30000 milliseconds) while waiting for the SharePoint 2010 Administration service to connect.
Event Xml:
<Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event”&gt;
<System>
<Provider Name=”Service Control Manager” Guid=”{555908d1-a6d7-4695-8e1e-26931d2012f4}” EventSourceName=”Service Control Manager” />
<EventID Qualifiers=”49152″>7009</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime=”2013-11-12T10:22:33.356089300Z” />
<EventRecordID>5148</EventRecordID>
<Correlation />
<Execution ProcessID=”536″ ThreadID=”540″ />
<Channel>System</Channel>
<Computer>xxxxxxxxxxxxxx</Computer>
<Security />
</System>
<EventData>
<Data Name=”param1″>30000</Data>
<Data Name=”param2″>SharePoint 2010 Administration</Data>
</EventData>
</Event>

 

7000

Log Name:      System
Source:        Service Control Manager
Date:          12.11.2013 11:22:33
Event ID:      7000
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxxxxxxxxxxxx
Description:
The SharePoint 2010 Administration service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.
Event Xml:
<Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event”&gt;
<System>
<Provider Name=”Service Control Manager” Guid=”{555908d1-a6d7-4695-8e1e-26931d2012f4}” EventSourceName=”Service Control Manager” />
<EventID Qualifiers=”49152″>7000</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime=”2013-11-12T10:22:33.356089300Z” />
<EventRecordID>5149</EventRecordID>
<Correlation />
<Execution ProcessID=”536″ ThreadID=”540″ />
<Channel>System</Channel>
<Computer>xxxxxxxxxxxx</Computer>
<Security />
</System>
<EventData>
<Data Name=”param1″>SharePoint 2010 Administration</Data>
<Data Name=”param2″>%%1053</Data>
</EventData>
</Event>

 

Der Microsoft Artikel http://support.microsoft.com/kb/2677070/en-us brachte keine Besserung.

Lösung:

Der Timeout für die Dienste muss erhöht werden.

– regedit

– HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

– Neu DWORD

– Name ServicesPipeTimeout

– Value (Dezimal) 60000

 

Server neu starten und der Dienst startet wieder automatisch nach einem Neustart des Servers.

 

 

 

Mit folgenden Befehlen kann man sich die verbleibenden Tage (von 120) eines nicht lizenzierten Terminalservers anzeigen lassen:

Command Line

wmic /namespace:\\root\CIMV2\TerminalServices PATH Win32_TerminalServiceSetting WHERE (__CLASS !="") CALL GetGracePeriodDays

Powershell

(Invoke-WmiMethod -PATH (gwmi -namespace root\cimv2\terminalservices -class win32_terminalservicesetting).__PATH -name GetGracePeriodDays).daysleft

Beim Versuch sich an einem Remotedesktop Server mit Windows Server 2008 R2 anzumelden erscheint folgende Fehlermeldung wenn bei dem Benutzerobjekt die Option “User must change password at next logon” aktiv ist:

Remotedesktopverbindung

Sie müssen Ihr Kennwort ändern, bevor Sie sich zum ersten Mal anmelden. Aktualisieren Sie das Kennwort, oder wenden Sie sich an den Systemadministrator bzw. an den technischen Support.

Lösung:

Die Default.rdp oder die jeweilige Verbindung mit Notepad öffnen und folgende Zeile einfügen:

enablecredsspsupport:i:0

Anbei ein Powershell Script welches eine neue Citrix Policy erstellt und bestehende ändert:

           Add-PSSnapin Citrix* -ErrorAction SilentlyContinue
 
           # Computer Policy Maintenance
            New-Item LocalFarmGpo:\Computer\MAINTENANCE
            cd LocalFarmGpo:\Computer\MAINTENANCE\Settings\ServerSettings
            Set-ItemProperty .\LoadEvaluator State Enabled
            Set-ItemProperty .\LoadEvaluator Value Maintenance
            cd LocalFarmGpo:\Computer\MAINTENANCE\Filters\WorkerGroup
            New-Item “MAINTENANCE” -Value “MAINTENANCE”
 
            # Computer Policy Unfiltered
            cd LocalFarmGpo:\Computer\Unfiltered\Settings\Licensing
            Set-ItemProperty .\LicenseServerHostName State Enabled
            Set-ItemProperty .\LicenseServerHostName Value LICENSESERVER
            Set-ItemProperty .\LicenseServerPort State Enabled
            Set-ItemProperty .\LicenseServerPort Value 27000
            cd LocalFarmGpo:\Computer\Unfiltered\Settings\ServerSettings
            Set-ItemProperty .\LoadEvaluator State Enabled
            Set-ItemProperty .\LoadEvaluator Value $LoadEvaluator
            cd LocalFarmGpo:\Computer\Unfiltered\Settings\XMLService
            Set-ItemProperty .\XmlServicePort State Enabled
            Set-ItemProperty .\XmlServicePort Value 8080
 
            # User Policy Unfiltered
            cd LocalFarmGpo:\User\Unfiltered\Settings\ICA\FileRedirection
            Set-ItemProperty .\AutoConnectDrives State Disabled
            Set-ItemProperty .\ClientDriveRedirection State Prohibited
            Set-ItemProperty .\ClientFixedDrives State Prohibited
            Set-ItemProperty .\ClientFloppyDrives State Prohibited
            Set-ItemProperty .\ClientNetworkDrives State Prohibited
            Set-ItemProperty .\ClientOpticalDrives State Prohibited
            Set-ItemProperty .\ClientRemoveableDrives State Prohibited
            cd LocalFarmGpo:\User\Unfiltered\Settings\ICA\Audio
            Set-ItemProperty .\ClientAudioRedirection State Disabled
            cd LocalFarmGpo:\User\Unfiltered\Settings\ICA\Printing\ClientPrinters
            Set-ItemProperty .\GenericUniversalPrinterAutoCreation State Enabled
            cd LocalFarmGpo:\User\Unfiltered\Settings\ICA\Printing\Drivers
            Set-ItemProperty .\InboxDriverAutoInstallation State Disabled
            Set-ItemProperty .\UniversalPrintDriverUsage State Enabled
            Set-ItemProperty .\UniversalPrintDriverUsage Value UpdOnly
            cd LocalFarmGpo:\User\Unfiltered\Settings\ICA\Printing
            Set-ItemProperty .\ClientPrinterRedirection State Enabled
            Set-ItemProperty .\DefaultClientPrinter State Enabled
            Set-ItemProperty .\DefaultClientPrinter Value “Set default printer to the client’s main printer”
            Set-ItemProperty .\AutoCreationEventLogPreference State Enabled
            Set-ItemProperty .\AutoCreationEventLogPreference Value LogErrorsOnly
            Set-ItemProperty .\WaitForPrintersToBeCreated State Disabled
            cd LocalFarmGpo:\User\Unfiltered\Settings\ICA\TWAINDevices
            Set-ItemProperty .\TwainRedirection State Prohibited
            cd LocalFarmGpo:\User\Unfiltered\Settings\ICA\USBDevices
            Set-ItemProperty .\UsbDeviceRedirection State Prohibited
            Set-ItemProperty .\UsbPlugAndPlayRedirection State Prohibited
            cd LocalFarmGpo:\User\Unfiltered\Settings\ICA\TimeZoneControl
            Set-ItemProperty .\SessionTimeZone State Enabled
            Set-ItemProperty .\SessionTimeZone Value UseClientTimeZone

In dem Crawl Log von SharePoint 2010 ist folgender Fehler zu finden:

sps3s://URL…

Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has “Full Read” permissions on the SharePoint Web Application being crawled. ( HttpStatusCode Unauthorized The request failed with HTTP status 401: Unauthorized. )

Access is denied

Lösung:

Der Search Access Account benötigt die Berechtigung “Retrieve People Data for Search Crawlers” für die User Profile Service Application:

CA -> Manage Service Applications -> User Profile Service Application -> Administrators -> Add Useraccount

Administrators for User Profile Service Application

Danach einen Full Crawl starten und schon sollte die Fehlermeldung nicht mehr auftauchen.

Um für das SapLogon Pad eine zentrale SAPLOGON.INI bereit zu stellen ist folgender Startparameter notwendig:

“<Pfad zur saplogon.exe>” /INI_FILE=<UNC Pfad zur SAPLOGON.INI>

Bei einer SharePoint 2013 Installation auf Windows Server 2008 R2 bin ich auf dieses Problem gestoßen.

Der Prerequisite Installer dauerte bis zu 1 Stunde und die meiste Zeit nahm der Installer von .net Framework 4.5 in Anspruch.

Der Grund war, dass auf dem Server bereits ein SQL Server 2008 R2 installiert war, nach Deinstallation dauerte das Framework nur noch wenige Minuten…

Entweder .net Framework vor dem SQL Server installieren oder mit der langen Installationsdauer leben 😉